12/10 EBSCO Maintenance

Incident Report for Holy Cross Libraries

Resolved

EBSCO is postponing this maintenance.
Posted Dec 09, 2025 - 17:07 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 09, 2025 - 14:13 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 09, 2025 - 14:12 EST

Update

We are continuing to work on a fix for this issue.
Posted Dec 09, 2025 - 14:11 EST

Identified

EBSCO Interfaces – Scheduled System Maintenance
Date: Wednesday, December 10, 2025
Time: 9:00 a.m. – 1:00 p.m. EST

EBSCO will perform scheduled system maintenance during the time window above. No service interruption is expected, but access or functionality may be slower than usual for the products listed below:

EBSCOhost Research Databases

CrossSearch/EBSCO Discovery Service

EBSCO eBooks

We apologize for any inconvenience this maintenance may cause and appreciate your understanding.
Posted Dec 09, 2025 - 14:11 EST
This incident affected: Ebooks (Ebsco Ebooks), Research Databases (Ebsco Databases), and CrossSearch.