12/8 EBSCO eBooks Maintenance

Incident Report for Holy Cross Libraries

Resolved

This incident has been resolved.
Posted Dec 08, 2025 - 12:05 EST

Monitoring

EBSCO will perform scheduled maintenance on the EBSCO eBooks system on Monday, December 8th, 2025, from 7:00 AM to approximately 12:00 PM. During the maintenance window:

Users will NOT be able to download DRM-protected eBooks
Users WILL be able to read eBooks online, download chapters, and read existing checkouts offline

We apologize for any inconvenience and appreciate your patience.
Posted Dec 05, 2025 - 09:36 EST
This incident affected: Ebooks (Ebsco Ebooks).